eKEY device compatability

The Supra eKEY application is continuously tested to the most recent Apple iOS and Android operating system. Notifications will be sent as Supra confirms OS compatibility with new operating systems.

Current operating system compatibility can be found here.

The following devices are not compatible: Palm, Windows Mobile, BlackBerry OS less than 4.5, and Apple OS less than 4.3.

BACK